Wednesday, October 24, 2012

Install Dell OpenManage Server Administrator on ESXi 5.1 - vSphere 5.1 Upgrade Post Activity

After the upgrading from ESXi 4.1 to ESXi 5.1, the Dell OpenManage Server Administrator (OMSA) previously installed on ESXi 4.1 was gone because it is not compatible.  So I need to re-install OMSA on my now ESXI 5.1 hosts.

The installation steps for OMSA on ESXi 5.1 are quite similar to the ESXi 4.1 as described in the entry http://deinfotech.blogspot.com/2011/08/installing-dell-openmanage-server.html.  However, you need to download the latest Dell OpenManage Offline Bundle and VIB for ESXi and Dell OpenManage Server Administrator Managed Node.  As of this writing, the version is 7.1.0, A00 and you can download them from the Dell website.

Dell OpenManage Offline Bundle and VIB for ESXi
http://www.dell.com/support/drivers/us/en/555/DriverDetails?driverId=Y0WHR

Dell OpenManage Server Administrator Managed Node
http://www.dell.com/support/drivers/us/en/04/DriverDetails?driverId=30T1C&fileId=2962652264

The first step is to install the Dell OpenManage Offline Bundle and VIB for ESXi on the ESXi 5.1 host.  In ESXi 4.1, you can use the vihostupdate.pl to do the installation but you can’t do it with ESXi 5.1.  if you try doing it, you will get the following error.

C:\Program Files (x86)\VMware\VMware vSphere CLI\bin>vihostupdate.pl --server es
xi02 -i -b c:\install\OM-SrvAdmin-Dell-Web-7.1.0-5304.VIB-ESX50i_A00
Enter username: root
Enter password:
This operation is NOT supported on 5.1.0 platform.

01_Operation is not supported

You will need to SSH to the ESXi 5.1 host and use the esxcli software vib install –d path_to_the_OMSA_VIB command to install it.

I used WinSCP to upload the Dell OMSA VIB package to the /tmp directory of the ESXi 5.1 host.  Do remember to enable SSH on the ESXi 5.1 host to allow SSH connection.

Then I used Putty to SSH to the ESXi 5.1 host and run the following command to install the VIB package.

esxcli software vib install –d /tmp/OM-SrvAdmin-Dell-Web-7.1.0-5304.VIB-ESX50i_A00.zip

02_Putty

After the install completed successfully, the ESXi 5.1 host needs to be restarted.  After the ESXi 5.1 host has restarted, select the host and go to the Configuration tab.  Click on Advanced Settings and you should see UserVars.CIMvmw_OpenManageProviderEnabled with the value set to 1.  In ESXi 4.1, this is UserVars.CIMoemProviderEnabled.

03_CIMvmw_OpenManageProviderEnabled

Now that the OMSA has been installed on the ESXi 5.1 host, the Dell OpenManage Server Administrator Managed Node needs to be upgraded as well.  If you use the older version to access the new OMSA on ESXi 5.1, you will get a cannot display the webpage error after you logon.

04_Cannot display the webpage

To upgrade or install a fresh copy of the Dell OpenManage Server Administrator Managed Node, just download the installation file from Dell website and run the executable file to install.

After you have completed the installation, just following the same steps shown in my http://deinfotech.blogspot.com/2011/08/installing-dell-openmanage-server.html entry to access the OMSA on the ESXi 5.1 host.

05_Access Successfully

9 comments:

Manav Sood said...

I tried all this but no luck. In my case I have also tried to telnet to port 1311 of the esx host and there is no response.

Also checked the services and seems like there is no DSM/DELL Service running, can you help me please?

Alex Siow said...

Hi Manav, which version of ESXi are you running?

Etienne Pouliot said...

I did the install like you said but i'can't connect with the remote ESXi 5.1

I always get login failed even tho I have the right ip and username/password.

Any idea how to find out if it actually try to login correctly ?

Should the data engine be running on the ESXi ? I get the following when I try to start it ? But i'm not sure if that's supposed to be running on ESXi :
/opt/dell/srvadmin/bin # /opt/dell/srvadmin/bin/dataeng start
Starting Systems Management Data Engine:
Starting dsm_sa_datamgrd: /opt/dell/srvadmin/bin/dataeng: line 1385: /opt/dell/srvadmin/sbin/dsm_sa_datamgrd: not found
FAILED
Starting dsm_sa_eventmgrd: /opt/dell/srvadmin/bin/dataeng: line 1385: /opt/dell/srvadmin/sbin/dsm_sa_eventmgrd: not found
FAILED

Etienne Pouliot said...

Ho well, not sure why but I ended up installing Dell OpenManage Server Administrator Managed Node on a Linux server (was on Windows) and it worked.

Manav Sood said...

Sorry Alex, just saw your comment. I am using ESXi 5.1

Alex Siow said...

Hi Etienne,

Great to know that you managed to get it running on a Linux server.

For the Windows Server, I suspect that the "Dell OpenManage Server Administrator Managed Node" is not working properly.

Alex Siow said...

Hi Manav,

After installing Dell OMSA VIB package on the ESXi host, do you see UserVars.CIMvmw_OpenManageProviderEnabled with a value of 1 in the Advanced settings.

You might want to check the OMSA daemons are installed. Enable the local shell mode and logon. Use the command "ps -s | grep dsm" without the double quotes to verify.

The Dell OpenManage Server Administrator Managed Node is the one listening on port 1311. You need to install Dell OpenManage Server Administrator Managed Node on a Windows machine and use that to connect to the OMSA on the ESXi host.

Ramon Ramirez said...

Great article! it was very easy to follow the steps you provided and now the server can be managed with no problem. Thank You.

Steven Jordan said...

Thanks! OMSA working again after ESXi 4.0 to 5.5 upgrade.